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1.  Introduction 

 
As a part of the curriculum, and for the partial fulfillment of the requirements for 
completion of the B.Tech degree from IIT Kharagpur, I, Subhrajit Bhattacharya, 
underwent an industrial training at the HED of L&T Limited., Powai Works for 8 
weeks during the two months period of May-June, 2005. 
 
L&T Limited., Powai Works, located at Powai, a place in Mumbai, is a vast industry 
with wide variety of disciplines. The primary engineering divisions that this industry 
possess are HED, E&C, ECC and EBG. Among them, HED (Heavy Engineering 
Division) is a manufacturing unit. In L&T Powai, HED primarily has got three 
Strategic Business Units (SBU) namely, FPEX, CGPP and RCOG. 
FPEX, FP3 was the department in which I was placed for the industrial training. This 
department is concerned with design and manufacture of Waste Heat Boilers. These 
equipments have vast application and demand in chemical industries, fertilizer plants, 
petroleum refineries, etc. The designs of these equipments are performed in multiple 
stages involving detailed calculations and complex analysis to provide maximum 
safety. But care also needs to be taken to prevent over designing, which will otherwise 
increase the material and manufacturing costs as well as the equipment weight making 
the transportation difficult and expensive. 
Hence the HED of Powai Works has a huge department concerned with the designing 
of the equipments, besides the gigantic workshops where manufacturing of the 
equipments take place. 
 
Under the guidance of Mr. N.R.Raykar, Senior Manager, HED, I got the opportunity 
to have exposure to the works carried out in this department of the industry, and hence 
learn a good deal from them. During the period of two months of industrial training, 
the works primarily assigned were concerned with finite element analysis and allied 
topics. A brief discussion on the assignments given and training undergone during this 
period follows. 
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2. Assignments completed during training 

 
Below is listed the primary tasks assigned and completed during the period of 
training. Brief discussions on each of the assignments will follow under the remaining 
sub-sections of Section 2. The Procedures developed, Documentations made and the 
Results obtained are described in the Appendices, after Section 2. 
 

1. Study on ASME Section VIII, Division-2, Appendix-4 
i. Study on stress categorization. 
ii. Study on definitions of Plastic analysis, Limit analysis, Collapse Load 

and Shakedown analysis as described in ASME Section VIII, Division-
2, Appendix-4 code. 

 

2. Plastic analysis – theory and FE Analysis 
i. Literature survey on Plastic Analysis. 
ii. Preparation of procedure for Elastic-Plastic Analysis using Ansys. 
iii. Preparation of procedure for Shakedown analysis using Ansys. 
iv. Development of a procedure and a MS Visual Basic code for finding 

Shakedown Load using Melan's theorem. 
v. Carrying out Plastic and Shakedown analysis with a pre-solved 

problem and validation of the results with ‘Design by Analysis CD 
Manual’ issued by European Pressure Equipment Research Council. 

 

3. FE Analysis of a Tube-Tubesheet joint of a Boiler. 
i. Using Contact elements to simulate thermal and mechanical contact 

between two surfaces. 
ii. Performing the solution and analyze the obtain results. 
iii. Preparing report of the analysis. 

 

4. Working on and developing tools for Material Property Database in MS 
Access using MS Visual Basic. 

i. Assisting in the development of a material property database using MS 
Access based on the ASME Section II, Part D code. 

ii. Development of a form using VB macro to seek information from the 
database and interpolating at intermediate temperature points. 

iii. Development of a form using Visual Basic macro to list, edit and add 
to the database. 

 

5. Working with universal files of FE softwares I-DEAS and NISA 
i. Improving the I-DEAS to NISA universal file translator to incorporate 

Pressure, Convection and Temperature boundary conditions, DOF 
constraints, and the various element types including first, second and 
third order axisymmetric, plane, solid and shell elements. 

ii. Development of a code to convert the MS Access database to I-DEAS 
universal file. 

 

6. Other short side-assignments 
i. Theoretical calculation of stresses on the welds and bolts of the support 

used for holding a pressure vessel in the workshop. 
ii. Collection of material test data from job files. 
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2.1. Study on ASME Section VIII, Division-2, Appendix-4 code 

Designs in L&T HED are generally done to ensure that they abide by the rules and 
restrictions imposed by ASME design codes. The ASME codes for design of pressure 
vessels, heat exchangers and boilers give detailed rules for the design of these 
components. Stress categorization is one of the most important procedures used for 
determining whether a stress field produced under a particular load condition violated 
the allowable limits. 

 
2.1.1. Stress Categorization 

In a complex structure under various combinations of loading, it is of great 
importance to identify the primary, secondary, membrane, bending and peak stresses. 
These stresses don’t have equal effect on the structure and hence their importances are 
different. Moreover the allowable limits on them are significantly different from each 
other. 
 

2.1.1.1. Primary, secondary and peak stresses 

In order to identify the primary, secondary and peak stresses in a structure, one may 
proceed according to the definitions given in ASME Section VIII, Division-2, 
Appendix-4 code. The code makes the major distinction between the primary and 
secondary stresses by saying that primary stresses are not self-limiting, while the 
secondary stresses are self-limiting. This implies that the primary stresses are the ones 
caused by external mechanical loading, while secondary stresses are caused by 
structural discontinuities, differential thermal expansion, etc. Primary stresses are 
generally responsible for gross deformation of structures. Secondary stresses are 
generally self-equilibrating and are of lesser severity than primary stresses. 
Peak stresses account for any other causes of stress in the structure, and are generally 
confined to local regions of the structure. Peak stress may cause fatigue, but not gross 
deformation of a structure. 
 

2.1.1.2. Membrane and bending 

Each of the primary and secondary stresses are again classified as membrane and 
bending stresses. To find the membrane and bending stresses, the components of 
stresses along a particular section of the structure (say, along the thickness of a 
pressure vessel) need to be linearized. That is, if we know a stress component (say 
σxx) as a function of l, the distance variable along the path (where l varies from –L/2 to 
+L/2, L being the length of the path), we need to express it as, 
σxx(l) = k1 + k2·l + σxx,peak(l), where k1 and k2 are constants determined using mean and 
linear regression of σxx(l). Hence, k1 = σxx,membrane and k2·l = σxx,bending. 
Hence the stress tensors for membrane and bending stresses are obtained along the 
section. From the stress tensors, applying Tresca’s yield criteria, the corresponding 
stress intensities can be determined. According to ASME Section VIII, Division-2, 
Appendix-4 code, the following allowable stress limits have been imposed on the 
stress intensities, 
Primary membrane (PL) + Primary bending (Pb) stresses ––  1.5kSm. 
Primary (PL + Pb) + Secondary (Q) ––  SPS
Primary (PL + Pb) + Secondary (Q) + Peak (F) –– Sa
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Where, i) Sm is the allowable stress for the material as given in ASME Section II, Part 
D, Table 2A and 2B; ii) k is a factor depending on the types of loading (e.g. internal 
pressure, wind load, earthquake, etc.) and is given by Table AD-150.1 of Section 
VIII, Division-2, Appendix-4; iii) SPS is the maximum of 3Sm and 2Sy, where Sm and 
Sy are the tabulated allowable and yield stresses respectively, averaged on the highest 
and lowest operating temperatures; iv) Sa is obtained from the fatigue curves given in 
Section VIII, Division-2, Appendix-5 and depends on the ultimate tensile strength of 
the material and the number of operational cycles for the equipment. 

 
2.1.2. Plastic Analysis 

According to ASME VIII Division 2 Appendix 4-136.5, “The limit of general 
membrane stress intensity… local membrane stress intensity… and primary 
membrane plus primary bending stress intensity… need not be satisfied at a specific 
location if it can be shown that the specified loadings do not exceed two-thirds of the 
plastic analysis collapse load determined by application of 6-153…”. 
However, the procedure for determination of collapse load according to Appendix 6-
153 is based on some experimental analysis of the actual structure, which hence can’t 
be used for theoretical predictions or Finite Element Analysis. Though any further 
clarification of the procedures for Plastic Analysis has not been provided in the code, 
the above-mentioned rule shows prospective potential for performing plastic analysis 
of a structure. 
 

An alternative to Plastic Analysis is Limit analysis, which has been described under 
ASME VIII, Division 2, Appendix 4-112 as “a special case of plastic analysis in 
which material is assumed to be ideally plastic”. In Appendix 4-136.3, Limit 
Analysis is described as, “The limit on general membrane stress intensity… local 
membrane stress intensity… and primary membrane plus primary bending stress 
intensity… need not be satisfied at a specific location if it can be shown by limit 
analysis that the specified loadings do not exceed two-thirds of the lower bound 
collapse load.”. This ‘Collapse Load’ for limit analysis is basically the ‘Lower bound 
Collapse Load’, which is described in 4-112 as, “…the maximum load a structure 
made of ideally plastic material can carry. The deformations of an ideally plastic 
structure increase without bound at this load, which is termed collapse load.” 
 

As mentioned before, no specific procedure for Plastic analysis was available from 
the code. Hence, further investigation into the subject was encouraging. The result of 
the literature surveys and understandings on Plastic Analysis has been described next 
in Section 2.2.1. 
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2.2.  Plastic analysis – theory and FE Analysis 2.2.  Plastic analysis – theory and FE Analysis 

The ASME, Section-VIII, Division-2, Appendix-4 code gives detailed procedure for 
calculation of stress intensities and stress categorization. However the permissible 
limits set to the different categories of stresses are completely bases on elastic 
analysis and ensures that using such limits won’t let the material cross the yield point. 
However this often leads to over-designing. Logically, some parts of the vessel may 
be allowed to go beyond the yield point of the material as long as it remains bounded 
in volume by surrounding materials in elastic region. Though this would cause some 
portions of the structure to get into plastic region, but will still not allow failure or 
gross deformation of the structure. Plastic analysis aims at such designing allowing 
plastic behavior of some parts of the structure. 

The ASME, Section-VIII, Division-2, Appendix-4 code gives detailed procedure for 
calculation of stress intensities and stress categorization. However the permissible 
limits set to the different categories of stresses are completely bases on elastic 
analysis and ensures that using such limits won’t let the material cross the yield point. 
However this often leads to over-designing. Logically, some parts of the vessel may 
be allowed to go beyond the yield point of the material as long as it remains bounded 
in volume by surrounding materials in elastic region. Though this would cause some 
portions of the structure to get into plastic region, but will still not allow failure or 
gross deformation of the structure. Plastic analysis aims at such designing allowing 
plastic behavior of some parts of the structure. 
As mentioned in the previous Section, the ASME code requires the determination of 
‘collapse load’ for the plastic analysis. Hence it was also of great interest to find a 
method for determining collapse load of a structure. 

As mentioned in the previous Section, the ASME code requires the determination of 
‘collapse load’ for the plastic analysis. Hence it was also of great interest to find a 
method for determining collapse load of a structure. 

  
2.2.1. Literature survey on Plastic Analysis 2.2.1. Literature survey on Plastic Analysis 

A study was performed on Plastic Analysis and informations on already existing 
theories and recent developments on the field were gathered. The primary sources of 
the informations were some textbooks on mechanics if materials and ASME Journal 
of Pressure Vessel Technology. This helped in the further studies and analysis. A 
short account on the results of the studies follows. 

A study was performed on Plastic Analysis and informations on already existing 
theories and recent developments on the field were gathered. The primary sources of 
the informations were some textbooks on mechanics if materials and ASME Journal 
of Pressure Vessel Technology. This helped in the further studies and analysis. A 
short account on the results of the studies follows. 
  

2.2.1.1. Lower Bound Collapse Load 2.2.1.1. Lower Bound Collapse Load 

ASME code describes this load as “…the maximum load a structure made of ideally 
plastic material can carry. The deformations of an ideally plastic structure increase 
without bound at this load, which is termed collapse load.” This load is basically such 
that it produces a limiting statically admissible system of stresses that satisfies 
equilibrium conditions and stress boundary conditions. The actual collapse load is 
always greater than the Lower Bound Collapse Load. 

ASME code describes this load as “…the maximum load a structure made of ideally 
plastic material can carry. The deformations of an ideally plastic structure increase 
without bound at this load, which is termed collapse load.” This load is basically such 
that it produces a limiting statically admissible system of stresses that satisfies 
equilibrium conditions and stress boundary conditions. The actual collapse load is 
always greater than the Lower Bound Collapse Load. 
  

2.2.1.2. Upper Bound Collapse Load – a theoretical determination technique 2.2.1.2. Upper Bound Collapse Load – a theoretical determination technique 

In a system where the loading is dynamic and cyclical, the Upper Bound Collapse 
Load is defined as the Kinematically admissible system, obtained by selecting the 
displacement/strain rate system (e.g. the St. Vanent’s equation), and determining the 
flow rule. This gives, 

In a system where the loading is dynamic and cyclical, the Upper Bound Collapse 
Load is defined as the Kinematically admissible system, obtained by selecting the 
displacement/strain rate system (e.g. the St. Vanent’s equation), and determining the 
flow rule. This gives, 

kinematically admissible load = kinematically admissible load = 
workexternalunit

workinternal  

Where, the ‘internal work’ is the internal work done under some extreme load 
condition, and the ‘unit external work’ is the work of unit load on 
a selected displacement rate system. The method for determining 
this load is illustrated using a simple example of a thin shell. 
Let’s consider a small element of the shell of thickness t and the 
material Modulus of Elasticity Y. As shown in the figure, the 
element is subjected to membrane stresses Nθ and Nφ, and 
bending moments Mθ and Mφ. 

 

Mφ 

Mθ 

Nφ 

Nθ 

  fig - 1 
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For finding nondimensional stresses, we define N0 = Yt and M0 = Yt2/4, For finding nondimensional stresses, we define N
and nθ = Nθ / N0 , nφ = Nφ / N0 , mθ = Mθ / M0 , mφ = Mφ / M0 . and n

0 = Yt and M0 = Yt2/4, 

Then the stress vector is defined by, S = (nθ, nφ, mθ, mφ). Then the stress vector is defined by, S = (n
θ = Nθ / N0 , nφ = Nφ / N0 , mθ = Mθ / M0 , mφ = Mφ / M0 . 

Next to find the strain rate vector, we first need to assume a displacement rate field. 
The displacement rate field may be calculated from the information of amplitude and 

frequency of loading/unloading. Let this displacement rate vector be U . From this, 
the strain rate vector may be calculated the same way the strains are calculated from 
displacements. 

Next to find the strain rate vector, we first need to assume a displacement rate field. 
The displacement rate field may be calculated from the information of amplitude and 

frequency of loading/unloading. Let this displacement rate vector be U . From this, 
the strain rate vector may be calculated the same way the strains are calculated from 
displacements. 

•

θ, nφ, mθ, mφ). 

Let this strain rate vector be , where, Let this strain rate vector be , where, ),,,(
....

φθφθ εε kkmm=
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 and  being the angular velocities. Then the internal work will be given by, θχ
.

φχ
.

∫
••

=
structurewhole

int dVNW ES0  

and the unit external work is given by, 

∫
••

=
structurewhole

ext dVW U . 

Hence, kinematically admissible load = Pka = 
••

extint WW . 
Proceeding in the above mentioned manner, expressions for collapse loads have been 
derived for various structures in the book ‘Pressure Vessel Design& Analysis’ by 
Bickel and Ruiz. 
 

2.2.1.3. A theoretical technique for calculation of Plastic Collapse Load 

This technique, as described in the book by Bickel and Ruiz, is based on the fact that 
at the collapse load, small increment in the external load will cause infinitely large 
deformations in the structure, hence cause infinitely large changes in strain. Hence, 
the primary aim of this technique is to find a relation between the external load (P) 
and a characteristic strain for the structure (e.g. may be strain at the internal or 
external circumference of a pressure vessel). Bellow is given a schematic description 
of how this method can be applied to find collapse load for a cylindrical pressure 
vessel. 

If u = radial displacement at a point; and εr and εθ are the 
logarithmic radial and hoop stresses, then, 

P 

u 1−=
∂
∂

re
r
u ε  and 1−= θεe

r
u

. 

For incompressibility, εr = -εθ . 
Two quantities called significant stress and significant 
strain are defined as, 

rσσσ θ −= , and   fig - 2 

θεεε
3

2
3

2
=−= r , 

which are related to each other by the stress-strain curve. [e.g. in case of perfectly 
linear and elastic material εσ ⋅= E .] 
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From the above equations, eliminating u; expressing σθ in terms of σr and σ ; and 
expressing εr and εθ in terms of ε , the equation obtained is given by, 

ε

εσσ
31 e

dd r
−

⋅
=  

Now, using boundary conditions σr = -P, iεε =  at r = ri ; and σr = 0, oεε =  at r = ro , 
for this specific example, we obtain, 

∫ −

⋅
=

o

i e
dP

ε

ε
ε

εσ
31

. 

Considering that collapse occurs when the strain at inner circumference increases 
indefinitely, the collapse point is given by, 

0=
∂
∂

i

P
ε

. 

Hence, knowing the stress-strain relation curve, it is possible to determine exactly the 
load (P) at which collapse occurs. 
 

2.2.1.4. First Yield Load and Limit Load for a thick-walled pressure vessel 

As described in ‘Pressure Vessel Design Concepts and Principles’ by J. Spence and 
A.S.Tooth, a pressure vessel under internal pressure assuming elastic-perfectly plastic 
material and Tresca’s Yield criteria, some simple calculations involving equilibrium 
considerations give, 
The load at which the material at the inner circumference first crosses the Yield point 

= First yield load =
⎥
⎥
⎦

⎤

⎢
⎢
⎣

⎡
⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
−=

2

0

1
2 r

r
P iy

y

σ
. 

The load at which the whole material of the vessel cross yield point and the vessel 

collapses by expanding indefinitely = Limit load = ⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
⋅=

i

o
yL r

r
P lnσ . 

These expressions are useful for quick and approximate calculations. 
 

2.2.1.5.  Limit Load Multipliers and their significances 

In the paper entitled “A Finite Element Technique for Limit Analysis of Structures”, J. 
Pressure Vessel Technology, Vol-112, p-138, quantities (denoted by m) called limit 
load multipliers have been defined. Then the Lower bound theorem states ms ≤ m* , 
and the Upper bound theorem states mk ≥ m* , where the limit load multipliers are 
defined as, 

max

2

f
kms = , where, fmax is the maximum value of the quantity σσ cf T

2
1

=  within 

the structure, with σ as the stress components expressed in a vector form, and c  being 
a constant matrix, k being a constant. 
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And, And, ∫=

V
k dVg

V
m 211 , the integration being done over the entire volume of the 

structure, where, εε cg T2= , with ε as the strain components expressed in a vector 
form. 
And  m*  is the multiplier which actually gives the collapse load. 
From the above, the following conclusions can be drawn, 

o The Lower bound limit load is dependent on the stress conditions in the 
structure, and is inversely proportional to the square-root of the quantity fmax, 
which is a measure of the maximum total stress in the structure. 

o The Upper bound limit load is dependent on the strain conditions in the 
structure, and is proportion to the mean value of g, which is a measure of total 
strain. 

o If the values of ms and mk are plotted with the load, the point of intersection of 
the two plots will indicate the collapse load. 

 
2.2.1.6. Shakedown or cessation of plastic deformation (work-hardening) 

 

  
σ 

 As shown in the adjacent stress-strain plot (fig-3), due to 
repeated loading and unloading between ε = 0 and ε = εmax , 
the material follows the path ABCD… and finally approaches 
the straight line PQ with a permanent plastic strain of εp and 

2.2.1.7.
Y

Y' 

εmax 

the maximum strain of εmax. This phenomena is known as 
shakedown. Generally, it is assumed, εmax ≤ 2Y / E. 
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A very special case of the stress-strain curve described above 
is that of elastic-perfectly plastic material. The corresponding 
stress-strain relation is plotted in fig-4. Though this is a highly 
idealized and approximate representation of the actual material 
behavior, an elastic-perfectly plastic material model performs 
fairly well when it comes to elastic-plastic and shakedown 
analysis of a structure. 

ε

 
 
 
 
 

ng analysis of structures under cyclic variation of secondary stresses 
rimary Effective Stress 

 described in the paper entitled “A Design Rule for Thermal 
essure Vessel Technology, Vol-108, p-188, involves the evaluation 
ed Primary Effective Stresses (Peff) and comparison of this quantity 
m stress in the structure. Below is described the steps involved in 
a particular point in the structure: 
tructure be undergoing cyclic external loadings. Elastic analysis of 
ture is performed under the different extreme load conditions (say, 
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fully loaded and no load conditions). Hence the stress fields are obtained at 
these loadings. 

ii. Distinguish between the primary and secondary stresses at each of these 
loading conditions. 

iii. Now, considering a particular point in the structure, let the maximum 
intensity (i.e. Tresca’s Equivalent) of primary stress at the point be P. 

iv. Let the range of secondary stress intensity variation be QR. 
v. The Secondarity Ratio is then calculated as, SQ = QR / P . 
vi. Once the value of SQ is obtained, one need to consult the Efficiency 

Diagram (a plot between SQ and V, determined on experimental basis, and 
is given in J.Pressurs Vessel Technology, fig-15, Vol-108, p-194.) to 
determine the Efficiency Index, V. 

vii. The Effective Primary Stress is hence calculated as, Peff = P / V. 
 
This Peff  is a fictitious quantity and is basically the stress, which on application for 
the same time gives strains as that of the real cyclic loading. 
The condition for no ratcheting to take place is generally taken as Peff  ≤ 1 to 1.2 Sm. 
 

2.2.1.8. Detailed Elastic-Plastic Analysis of thick-walled cylindrical vessels 

In the group of papers entitled “Elastic-Plastic Analysis of Tubes”, J.Pressure Vessel 
Technology, Vol-114, p-213, the author W.Jiang has performed detailed theoretical  
calculations for thick cylinders under various types of cyclic loadings and has 
deduced various modes of shakedown. In this paper, the term ‘shakedown’ has been 
used in a more generalized sense and has referred to any steady-state response of a 
system under any cyclic loadings. The primary features of the analysis performed in 
the paper are, 

o Detailed expressions for σθ, σr and τ have been derived for cylinders with 
internal and external pressures and also rotating with a constant angular 
velocity. 

o The analysis apparently uses von Mise’s yield criteria. 
o For shakedown analysis, two loads are assumed (upper and lower) and the 

stresses are determined at each of them. 
o 9 different modes of shakedown (i.e. 9 solutions for the differential equations 

depending on the boundary conditions, loads and the geometric parameters) 
has been deduced – 1 purely elastic, 2 elastic, 3 reversed plastic and 3 
ratcheting. 

o Ratcheting analysis has also been performed, where the values of σθ, σr and τ 
have been derived at the kth cycle of loading/unloading. It was then checked 
whether those values remain bounded as k→ ∞. 

 
2.2.1.9. An alternative method for finding Lower bound Limit Load (J.PVT, vol-116, p-340) 

Let a structure be subjected to a cyclic loading. Let a load Pd be applied on the 
structure at a particular instant of time. The corresponding stress field be, σs , 
determined from analysis of the structure. The Lower bound Limit Load is then given 
by, 

⎟
⎟
⎠

⎞
⎜
⎜
⎝

⎛
=

max

max
s

Y
dtl PP
σ
σ  
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where, the function max t ( ) denotes maximum of all the values inside the brackets 
obtain at various instants of time, i.e. maximum over time; While 

maxsσ  is the 
maximum stress intensity inside the structure at a particular time instant, i.e. 
maximum over space; And σy is the Yield strength. 
 

2.2.1.10. Melan’s Theorem – Determination of Shakedown Load from Limit Collapse Load 

The Melan’s theorem is base on determination of a self-equilibrating stress field, 
(σij )res  defined as, 

(σij )res = (σij )ep,l  –  (σij )le,l 
 
Where,  (σij )ep,l  is the stress field for the structure made up of elastic-perfectly plastic 
material under the Limit load or the Lower bound Collapse Load ( l ), and (σij )le,l  is 
the stress field under the same load ( l ) but using a linearly elastic material model. 
Once the residual stress field is determined, it is multiplied by a factor ‘β’ to bound 
the stress field, 

(σij )res,co = β·(σij )res 
 
such that (σij )res,co  does not violate the Yield criteria at any point in the structure. 
β may be 1 when the uncorrected self-equilibrating stress field does not violate yield 
conditions. Then the shakedown load is the limit collapse load. 
After this, the corrected stress field (σij )res,co is superimposed on a scaled version of 
the linearly-elastic stress field such that it does not violate the yield condition, 
 

(σij )SD = (σij )res,co + α·(σij )le,l 
 

where, α is the scaling factor. The value of α to be taken should be the highest 
possible one for which (σij )SD  does not violate the yield conditions. 
Then, if Plim denotes the limit collapse load, then the Shake-down load is determined 
by, 

PSD = α·Plim 
The application of Melan’s Theorem has been described later in procedure for 
determination of shakedown load. 

 
2.2.2. Preparation of procedure for Elastic-Plastic Analysis using Ansys – to determine 

Limit Collapse Load 
 
The Finite Element Analysis software Ansys 8.0 was extensively explored to 
determine how elastic-perfectly plastic material properties are declared and the non-
linear analysis is performed. The main objective was to determine the ‘Lower bound 
collapse load’ – the load at which gross deformation of the structure is about to begin. 
By using an elastic-ideally plastic material model, this particular load was determined 
by the load at which numerical instabilities begin and the solution starts diverging. 
The detailed stepwise procedure developed as a part of the given assignments during 
the training has been described in Appendix-A. 
This procedure has then be used to find the collapse load for a problem described in 
the ‘Design by Analysis CD Manual’ issued by European Pressure Equipment 
Research Council, University of Strathclyde. In that CD Manual, the collapse load for 
the structure has already been determined by some alternative route. The results 
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obtained by the method described in Appendix-A were in satisfactory agreement with 
those of the manual. The details of the results obtained can be found in Appendix-F. 
 

2.2.3. Preparation of procedure for Shakedown analysis using Ansys – to determine whether 
shakedown takes place at a particular load condition 
 
To determine whether Shakedown takes place under a given load cycle, Ansys 8.0 
was used to perform the solution (static or transient) at several load-steps to simulate 
the cyclic loading and unloading. The details of the procedure developed is given in 
Appendix-B. 
This procedure was used to check whether Shakedown takes place at the Shakedown 
load determined by Melan’s Theorem (section 2.2.4.). Shakedown was found to take 
place at that load. Appendix-F gives the details of the results obtained. 

 
2.2.4. Development of a procedure and a VB code for finding Shakedown Load using 

Melan's theorem 
 
As described in section 2.2.1.10., the Melan’s Theorem requires a fairly large amount 
of calculations involving the stress fields. Initially it was attempted to perform the 
calculations using Ansys Element Tables. But on finding that this leads to lots of time 
consuming complications, some alternative way was searched for. 
The easiest alternative solution found was to export the stress fields in ASCII file 
format from Ansys and directly operate with them using a computational code written 
in some programming language to find the values of α and β . 
Hence, a code was written in MS Visual Basic which would take input the exported 
stress fields (σij )ep,l  and  (σij)le,l  from Ansys and the Yield strength value, and will 
output the values of α and β . 
This program was used with the same problem of ‘Design by Analysis CD Manual’ . 
The values of α and β have also been evaluated in the CD manual using some other 
methods. The values obtained using the VB program was found to be in excellent 
agreement with those of the CD Manual. 
The attempted procedure for Melan’s theorem evaluation using Ansys Elements Table 
is given in Appendix-C. The procedure for exporting the stress fields from Ansys and 
using the VB code to determine α and β is given in Appendix-D. The pseudo-code 
used in the VB program has been described in Appendix-E. The verification of the 
values of α and β obtained from the code is given in Appendix-F. 

 
2.2.5. Carrying out Plastic and Shakedown analysis with a pre-solved problem 

As mentioned earlier, the procedure for determining Limit Collapse Load (Appendix-
A), Shakedown Load using Melan’s Theorem (Appendix-D), and verifying whether 
Shakedown takes place at that load (Appendix-B) has been validated by re-solving a 
FE problem already solved in ‘Design by Analysis CD Manual’ issued by European 
Pressure Equipment Research Council, University of Strathclyde. The results obtained 
were in good agreement with those of the CD Manual. The details are described in 
Appendix-F. 
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2.3. FE Analysis of a Tube-Tubesheet joint of a waste heat boiler 2.3. FE Analysis of a Tube-Tubesheet joint of a waste heat boiler 

The boiler studied was basically a shell and tube type heat exchangers which consist 
of several U-shaped tubes attached to a tubesheet. Through these tubes hot corrosive 
gasses flow, and comparatively cooler water that flow over the tubes. The whole 
assembly resides inside a pressure vessel. The analysis aimed at simulating an 
axisymmetric model of a single tube attached to the tubesheet and investigation of 
whether the allowable stress intensity limits are exceeded at any portion of the model. 

The boiler studied was basically a shell and tube type heat exchangers which consist 
of several U-shaped tubes attached to a tubesheet. Through these tubes hot corrosive 
gasses flow, and comparatively cooler water that flow over the tubes. The whole 
assembly resides inside a pressure vessel. The analysis aimed at simulating an 
axisymmetric model of a single tube attached to the tubesheet and investigation of 
whether the allowable stress intensity limits are exceeded at any portion of the model. 
  

2.3.1 Using Contact elements to simulate thermal and mechanical contact between two 
surfaces 

2.3.1 Using Contact elements to simulate thermal and mechanical contact between two 
surfaces 

  
There is a layer of Inconel 600 material at the inner surface of the tube, which has 
been shrink-fitted during the manufacture process. This inside lining is called the 
Ferrule and is joined to the tubesheet at the bottom by a fillet weld, and is joined to 
the tube near the top by a small weld region. The remaining of the ferrule is not 
attached to the tube or tubesheet, hence there can be relative sliding motions between 
the outer surface of the ferrule and inner surface of the tube-tubesheet. In order to 
simulate this situation, contact elements had to be used to establish thermal contact 
and sliding mechanical contact between the two surfaces. The figures below give the 
schematic representation of the FE model along with the contact elements. 
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The dark blue spots between the ferrule and tube-tubesheet show the contact 
elements. The red circles marks the weld regions. The lettered sections are the places 
where stress linearization has been done. 
 

2.3.2. Solving the model and obtaining the results 

The model was created according to the dimensions given in the drawings for the 
Boiler. The materials and material properties chosen were according to the drawings 
itself. For the purpose of obtaining the material properties, ASME Section II, Part-D 
codes were used. The contact elements were generated between the appropriate 
surfaces. 
Appropriate boundary conditions were applied and the solution was performed. 
Because of presence of contact elements, the solutions were non-linear in nature. 
The details of the Elements used, Material Properties and Boundary conditions 
applied are given in Appendix-G. 
 

2.3.3. Interpreting the results and drawing conclusions 

The results obtained are described in Appendix-H. The stresses were linearized and 
categorized into membrane and bending stresses at some critical sections. From the 
obtained results the following conclusions could be made: 

o The categorized stresses are within the allowable limits in accordance to 
ASME Section VIII, Division-2, Appendix-4 code. 

o The maximum stress intensities are obtained near the weld regions. 
o The contact elements showed desired behaviors. They established thermal 

contact by showing continuity in temperature across the interface. Moreover 
Normal reaction was also transmitted between the surfaces which was 
reflected by the continuity in the x-component of displacement and the σxx 
component of the stress across the interface. However, sliding was allowed 
between the surfaces, which were reflected by the discontinuities in y and z 
component displacement plots. 

o The welds were modeled successfully as all the quantities showed continuity 
across the welds. 
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2.4. Material Property Database in MS Access 

ASME Section II, Part-D code is used extensively to obtain the property values for 
material for both Design by Formula and Design by Analysis. But there are some 
inherent disadvantages with reading from the code: 

o Owing to the massiveness of the code with thousands of materials and their 
property tables, reading property values from the code is not only difficult and 
time-consuming, but also is highly prone to errors. 

o The units for material properties used in the code are all in FPS system and the 
temperatures are in Fahrenheit. Hence, every time the properties are read from 
the code, they need to be converted to the desired unit systems. This is rather 
cumbersome and may give rise to errors. 

o The code provides the property values at some particular temperature points. 
In order to obtain the property values at some intermediate temperature, 
interpolation is required. Performing the interpolation manually every time is 
again tedious and prone to errors. 

 
Hence it would of great help if the material properties can be inputted into a computer 
database and then read, interpolated or even modified in any convenient unit system 
using a suitable computer program. This was exactly the target of this project and has 
been finally achieved successfully. 
 

2.4.1. Assisting in development of the material property database using MS Access 

The first step towards the development of the database was to design a structure for 
the database. After a considerable amount of discussions, thoughts and 
experimentations, a final structure for the database in MS Access was decided. The 
description of the structure of the database follows. 
 
The database makes use of one main table, ‘Materials’, containing the material names, 
compositions and references to parts of the ‘Data_’ tables containing the property 
values. The ‘Data_’ tables may be viewed as pools (or collections) of several sets of 
property values, to which references are made in the ‘Materials’ table. 
There is also a set of ‘ID_’ tables, whose soul purpose is to create one-to-many 
relationships between the ‘Materials’ and ‘Data_’ tables, which would otherwise had 
been many-to-many relationships. The user of the database may not be concerned 
much about the ‘ID_’ tables. 
Below are the salient features of the structure of the database. 
 

o The Field 0 (‘Material Name’) of the ‘Materials’ table contains the names of 
the different materials, and Field 6 (‘Composition’) contains the composition. 

o For each record in the ‘Materials’ table, the Fields 1, 2, 3, 4 and 5 contains a 
reference number or ‘ID’ of the properties ‘Modulus of Elasticity’, ‘Thermal 
Conductivity’, ‘Coefficient of Thermal Expansion’, ‘Thermal Diffusivity’ and 
‘Allowable Stress’ respectively. The ID refers to a particular set of values in 
the respective ‘Data_’ table which are the property values of the material. 

o There are 5 ‘Data_’ tables which contain several sets of the property values. 
Each set (identified by an ID) contains the property values at different 
temperature points. 

o All the units used in the database are same as those in ASME code in Section 
II Part D. Temperatures are in Fahrenheit. 
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A particular data set may be referenced by more than one material. Making changes in 
that data set will hence cause change in all those materials’ that property. 
A particular data set may be referenced by more than one material. Making changes in 
that data set will hence cause change in all those materials’ that property. 
  
Notes: Notes: 
i) A ‘Record’ refers to an entry in a table. i) A ‘Record’ refers to an entry in a table. 
ii) The term ‘Field n’ refers to the column (n+1) of the particular table or record. ii) The term ‘Field n’ refers to the column (n+1) of the particular table or record. 
iii) The term ‘property data set’ refers to a set of property values at different 

points of temperature. Each material property ‘Data_’ table contains several 
such sets, which in turn are referenced by the materials in the ‘Materials’ 
table to describe the corresponding property. For a particular property, a 
particular set has an unique ID number. 

iii) The term ‘property data set’ refers to a set of property values at different 
points of temperature. Each material property ‘Data_’ table contains several 
such sets, which in turn are referenced by the materials in the ‘Materials’ 
table to describe the corresponding property. For a particular property, a 
particular set has an unique ID number. 

  
The following diagram makes the structure of the database clear: The following diagram makes the structure of the database clear: 
  

 fig – 6:  Structure of the database – Displaying a property data set – 
Modulus of Elasticity values for material SA 182 Gr F11 

 
The procedure documented for working with the database manually has been 
described in Appendix-I. 



  Industrial Training Report 

Page  18 of 47 

 
2.4.2. Developing VB macros to work with the database 

The task of creating VB macros to read, interpolate and modify the database was next 
assigned. It was a bit difficult task to interact with MS Access using the Visual Basic 
macros because no proper help providing the desired informations was available in 
the help files. However, taking help of VB Object Browser all the tasks were finally 
completed. 
The descriptions of the two forms developed in the process along with their 
screenshots follow: 
 

2.4.2.1. The ‘Seek/Interpolate’ form 
 

 
fig - 7 

 
The salient features of the form are: 

o The user may select the required Material Name and Material Property from 
the drop-down lists. 

o The user may chose to view the output values of the material property in any 
desired unit system available in the drop-down list. The units of temperature 
can be chosen between C, F or K. 

o The user may click the ‘Open Materials Table’ button to open the ‘Materials’ 
table from the actual database at the position of the selected material. 

o The user may click the ‘Open Property Value database Table’ button to open 
the corresponding ‘Data_’ table from the actual database at the position where 
the presently displayed property values reside. 

 
The detailed procedure for working with this form was documented, and is given in 
Appendix-J. 
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2.4.2.2. The ‘List/Edit/Add’ form 

fig - 8 

The salient features of the form are: 
o The user may select the required Material Name and Material Property from 

the drop-down lists. 
o The user may chose the desired units for the material property and temperature 

to work with. 
o The user may modify or delete existing records in a property value data set, 

and also add new record to the database. 
o The user may add new materials to the database by typing the new name in the 

‘Material Name’ box, which will activate the ‘Add Material’ button. 
o The user may select from the existing compositions for the new material, 

which will accordingly assign IDs to some of the properties, or he/she may 
chose to enter a new composition. 

o The user may assign IDs from existing data sets to a property of a new 
material. 

 
The documentation on the detailed procedure for working with this form is given in 
Appendix-J. 
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2.5. Working with universal files of  I-DEAS and NISA 

Beside Ansys, I-DEAS and NISA are two Finite Element softwares which are used 
extensively for FE Analysis in the industry. This part of the project involved working 
with the universal files of these two softwares in order to interact with them and 
among them. 
The Universal Files are basically ASCII data files containing informations about the 
elements, nodes, constraints, boundary conditions, element types and material 
properties used in a FE model, placed under several blocks (bound by delimiters) or 
headers. Hence they can be read or modified on having a knowledge about the 
different dataset identifiers or headers and the formats in which the data are written in 
the Universal Files. These informations are documented in the I-DEAS Files Format 
Reference Guide manuals for I-DEAS universal files, and in the NISA users’ manual 
for the NISA universal files. 
 

2.5.1. Improving the I-DEAS to NISA universal file translator 

I-DEAS and NISA have got their own pros and cons. As for example, I-DEAS is 
excellent when it comes to modeling and meshing of complex structures because of 
it’s user-friendly and interactive modeling environment. Whereas the modeling 
environment of NISA is extremely poor and it takes lot of efforts even to view the 
model properly. On the other hand, with the present license of the I-DEAS that is 
being used, it is not possible to perform nonlinear analysis. But NISA can perform 
nonlinear analysis very well. 
Hence it was desired to find a way so that the modeling could be done in I-DEAS, 
while the solution can be performed in NISA. The possible way of making them 
interact with each other was their universal file formats for their models. But the 
Universal file formats of I-DEAS and NISA are remarkably different. Hence it was 
required to create a translator to convert the I-DEAS universal file to NISA universal 
file. Such a translator was already created and was in it’s elementary stage that could 
convert the informations about the nodes and elements. The task assigned regarding 
this translator was to improve it so that it can translate the informations about 
boundary conditions, loads, DOF constraints and different element types. This was 
achieved and the translator was improved so that it can also translate the following 
informations: 

o The type of analysis – Static or Thermal 
o Edge and Face Convection boundary conditions [I-DEAS Unv dataset no. 790; 

NISA dataset ‘*CONVBC’]. 
o Face Heat Flux boundary conditions [I-DEAS Unv dataset no. 790; NISA 

dataset ‘*DEFLUX’]. 
o Face Pressure [I-DEAS Unv dataset no. 790; NISA dataset ‘*PRESSURE’]. 
o Displacement restraint [I-DEAS Unv dataset no. 791; NISA dataset 

‘*SPDISP’]. 
o Temperature boundary conditions [I-DEAS Unv dataset no. 792; NISA dataset 

‘*NDTEMPER’]. 
o Element types (includes plane, axisymmetric, solid and shell elements of first, 

second and third orders) [NISA dataset ‘*ELTYPE’]. 
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2.5.2. Developing code for converting the MS Access materials’ database to I-DEAS 

universal file 
 
While performing FE analysis using I-DEAS, it is often required to input the material 
properties at different points of temperature so as to consider the variation of the 
material properties with temperature during the analysis. As the database created in 
MS Access contained the material properties at various points of temperature, it was 
of interest to export the information of the database to I-DEAS. For this purpose, a 
code was written in VB to convert the material properties in the database to an I-
DEAS universal file. The I-DEAS universal dataset number that dealt with the 
material properties was 1716. The program could successfully export all the desired 
material properties in the database at different temperature points to I-DEAS material 
database via the Universal file. 
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2.6. Other short assignments 2.6. Other short assignments 

Apart from the main tasks assigned during the training, there were several short side-
assignments, each of one to two days duration. Below is mentioned a few of them. 
Apart from the main tasks assigned during the training, there were several short side-
assignments, each of one to two days duration. Below is mentioned a few of them. 
  

2.6.1. Theoretical calculation of stresses on the welds and bolts of the support used for 
holding a pressure vessel in the workshop 

2.6.1. Theoretical calculation of stresses on the welds and bolts of the support used for 
holding a pressure vessel in the workshop 
  
A schematic (not to scale) representation of the problem is shown in the adjacent 

diagrams. 
A schematic (not to scale) representation of the problem is shown in the adjacent 

diagrams. 
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Longitudinal stresses on the weld = Longitudinal stresses on the weld = 
XXI

yM  

Stress on a bolt = Fi = k·yi  
 

tance of the point on the weld from the horizontal axis = R2 cos θ. 
ance of ith bolt from the horizontal axis = R1 cos θi. 
proportionality constant, determined on the basis of equilibrium 

consideration. 
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The final expression for the forces on ith bolt is given by, 
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And, the stress on the weld at a point at angular position θ is given by, 
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where t = weld throat thickness. 
 
For the particular problem, the geometric parameters were α = 35, β = 45, γ = 22.5, 
φ = 0, l1 = 0.6, l2 = 0.803, R1 = 0.68, R2 = 0.751, t = 0.0106, 
bolt c.s. area (A) = 0.00102. 
The load P was assumed to be half of the weight of the pressure vessel, P = 343000. 
The allowable bending/tensile strength was taken, 0.6Y = 1.49E+08. 
The allowable shear strength was taken, 0.45Y = 1.12E+08. 
All units in SI system. 
 
All the calculations were performed in MS Excel spreadsheet and the stresses in the 
bolts and welds were found to be well within the limits. The results are shown in 
Appendix-K. 
 
[Note: A more accurate and detailed approach would have been to use the following 

equations, 

Longitudinal stresses on the weld = 
( )

( )XXYYXY

YYXY

III
yIxIM

−
−

2  

Stress on a bolt = Fi = k1·yi  + k2·xi  
Where, IXX, IYY, and IXY can be determined by integration at section B, 
And k1 and k2 determined by both force and moment equilibrium consideration 
at section A.] 

 
2.6.2. Collection of material test data from job files 

This was a short task in which some material test result data were to be collected from 
job files. This helped in coming to know about how testing of materials are done in 
the industry, and to get familiarized with job files. 
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3. Appendices 

 
Appendix-A – Procedure developed for determination of Collapse Load using Ansys 

 
To determine the collapse load, the analyst must first chose a material model with 
elastic-perfectly plastic property. Such a material is defined by two parameters: 

a. The Modulus of Elasticity of the material in it’s elastic region, and 
b. The Yield Stress of the material. 

The above data must be available before starting the analysis. 
 
The analysis procedure is described below in a stepwise manner: 

i) Create the model using the tools given in ‘Preprocessor > Modeling’ 
menu. 

ii) Define the element type to be used for meshing from ‘Preprocessor > 
Element Type > Add/Edit/Delete > Add…’ For an axisymmetric model, 
typically the element ‘PLANE82’ under the ‘Structural mass > solid’ 
group may be chosen. 
a. If required, set any options for the element from ‘Preprocessor > 

Element Type > Add/Edit/Delete > Options…’ For an axisymmetric 
model, change the ‘Element behavior’ to Axisymmetric. 

b. Also set any required real constant value for the element from 
‘Preprocessor > Real Constants > Add/Edit/Delete’. This is totally 
dependent on the element used and the specific problem. For 
‘PLANE82’ there is no need for setting any real constant value. 

iii) Define the material properties from ‘Preprocessor > Material Props > 
Material Model’. Select the ‘Material model number 1’. 
a. Go to ‘Structural > Linear > Elastic > Isotropic’. Type the value of 

Modulus of Elasticity of the material in the ‘EX’ field and the 
Poisson’s ratio in the ‘PRXY’ field. Typically, the Poison’s ratio has 
value of 0.3. 

b. Go to ‘Structural > Nonlinear > Inelastic > Rate Independent > 
Isotropic hardening plasticity > Mises Plasticity > Bilinear’ and set the 
‘Yield Stress’ to yield stress of the material, and ‘Tangent modulus’ to 
0. 

c. Set any other property value if required. 
iv) Go to ‘Preprocessor > Meshing > Mesh Attributes > default attributes’ and 

make sure that the correct element, material and real constant set numbers 
are chosen. Select the size controls from ‘Size Cntrls > Smart size (or 
Manual Size)’. Mesh the model using the meshing tools given under 
‘Preprocessor > Meshing > Mesh’. 

v) Go to ‘Solution > Analysis type > New Analysis’. Select ‘Static’ and click 
‘Ok’. 

vi) Open the ‘Solution controls’ window from ‘Solution > Analysis type > 
Solution Control’. Now ensure that the following are done: 
a. Under the ‘Basic’ tab, make sure, 

i. ‘Automatic time stepping’ is ‘on’. 
ii. ‘Number of substeps’ is 20. 
iii. ‘Minimum number of substeps’ is 20. 
iv. ‘Maximum number of substeps’ is 100. 
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v. ‘Time at the end of loadstep’ is a value between 0.1 and 1. [For a 

quick and approximate solution use small value (0.1) for this 
parameter, while for a more accurate solution, typically chose 1.] 

vi. Select ‘write every substep’ from ‘Frequency’ under the ‘write 
items to result file’ block. 

b. Under the ‘Nonlinear’ tab, set the following nonlinear options: 
i. ‘Line search’ is ‘on’ 
ii. ‘Equilibrium iteration’ is 1000. [Typically this value should be 

high in order to ensure that Ansys gets enough scope to try to 
converge the solution. However, the analyst should also keep a 
careful eye on the convergence graphs during the solution and 
stop the solution if he/she feels the solution won’t converge, just 
to avoid mere wastage of time by reaching non-convergence after 
all the 1000 iterations.] 

 

vii) Chose a set of loads to be applied. Our primary aim is to determine the 
loads at which the solution is about to diverge. Hence the chosen load set 
is desirably some value near the collapse load. This may be done by some 
crude analytical calculation for determination of collapse load set. Let’s 
assume the analytically determined collapse load set is p. Then the actual 
collapse load will expectedly lie between 0.8p and 1.2p. So starting with 
0.8p will be a good idea. 
Anyway, the analyst may start with any value according to wish, because 
finally the actual collapse load will be achieved by a sort of iterative 
method. Let this first load set that is being applied be called P1. The 
consequent load sets applied be P2 , P3 , etc (see step (x) ). 

viii) Apply the load set (Pn for the nth step) using the tools given under 
‘Solution > Define Loads > Apply’ or ‘Preprocessor > Loads > Define 
Loads > Apply’. 

ix) Start the solution from ‘Solution > Solve > Current LS’. 
x) Now, two cases may arise: 

Case I: The solution converges. This implies that the collapse load is 
higher than the applied load. 
For convenience of further reference, note down the value of this 
load, and let it be called Pjust lower (i.e. load set just lower than the 
collapse load). 
Now an even higher load needs to be applied. If Pjust higher already 
exists, then chose a load somewhere between Pjust lower and Pjust 

higher , else chose something around 1.2p. Call it Pn+1. for the 
(n+1)th step. 

Case II: The solution diverges. This implies that the collapse load is lower 
than the applied load. 
For convenience of further reference, note down the value of this 
load, and let it be called Pjust higher (i.e. load set just higher than the 
collapse load). 
Now a lower load needs to be applied. If Pjust lower already exists, 
then chose a load somewhere between Pjust lower and Pjust higher . Call 
it Pn+1. for the (n+1)th step. 

xi) Delete the already applied load step from ‘Solution > Define Loads > 
Delete’ or ‘Preprocessor > Loads > Define Loads > Delete’. 
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xii) Repeat steps (viii) to (xi) until sufficiently close values of Pjust lower and Pjust 

higher are obtained. 
xiii) The load set Pjust lower approximately gives the collapse load, two-third of 

which gives the limit load. 

 
Appendix-B – Procedure developed for determining whether shakedown occurs at a particular 

Load set using Ansys 
 
To perform shake down analysis directly using Ansys, without using Melan’s 
Theorem, one may approach in similar iterative approach as described in Appendix-
A. That is, determine if shake down occurs at a particular load or not and then go on 
changing the loads in a trial and error fashion to finally determine the maximum load 
at which shakedown occurs. 
But the problem with this is that the shakedown analysis using Ansys is a bit time 
consuming process as it involves several loading-unloading cycles. Hence the 
following procedure may at most be used efficiently to predict if shakedown will take 
place under a particular given load, but not to determine the shakedown load. 
 
To perform a shakedown analysis, several cycles of loading and unloading need to be 
applied on the structure. Let the loads applied during loading be defined by a load set 
P. The loads applied during unloading will definitely be zero. We will perform four 
such cycles and see if shakedown occurs by then. 
 
Peruse the following steps to determine if shakedown occurs at the particular load set: 

i) Create the model, define element type, define material, and mesh the model as 
described in steps (i) to (iv) of Appendix-A. 

ii) Go to ‘Solution > Analysis type > New Analysis’. Select ‘Static’ and click 
‘Ok’. 
[ Note: 
By opting to perform a Static analysis we have eliminated any possible 
involvement of the inertia forces due to mass matrix. This will hence imply 
that the frequency of the loading-unloading cycles is very low (i.e. the cycles 
are very slow). The value of ∆t (see next step) hence will have no effect on the 
solution results. The analyst may chose any convenient value for ∆t. 
But if the analyst is interested in including the effects of cycle frequency and 
the inertia forces, he/she need to perform a transient analysis. To do this, select 
‘Transient’ from ‘Solution > Analysis type > New Analysis’. Then select 
‘Full’ from the window that pops up and click ‘Ok’. The remaining procedure 
is same as that follows. However the time required by Ansys to perform the 
solution will be much higher.] 

 
iii) Define the ‘Solution controls’ exactly as described in (vi) of Appendix-A. Let 

the value chosen for the parameter ‘time at the end of load step’ be ∆t. This 
value (∆t) will be referred later to define the load steps. 

iv) Apply the load set P from ‘Solution > Define Loads > Apply’ or ‘Preprocessor 
> Loads > Define Loads > Apply’. 

v) Go to ‘Solution > Load Step Option > Write LS file’. Enter ‘1’ as load step 
file number. Click ‘Ok’. 
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Note: By this process, the first load step has been written, which is the loading 

half of the first cycle. The time at the end of this first half of the first 
cycle was defined under ‘Solution controls’ as ∆t. As the same load 
needs to be applied in the first halves of 2nd, 3rd and 4th cycles, we can 
write the load step file numbers 3, 5 and 7 with the same load set, just by 
changing the ‘time at the end of load step’ for each. So we do in the 
following step. 

 

vi) In ‘Solution > Analysis type > Solution Control’, change ‘time at the end of 
load step’ to 3⋅∆t. Go to ‘Solution > Load Step Option > Write LS file’. Enter 
‘3’ as load step file number. Click ‘Ok’. 

vii) Similarly write the Load step files number 5 and 7, with ‘time at the end of 
load step’ as 5⋅∆t and 7⋅∆t respectively. 

viii) Next remove all the loads (but not the DOF constrains) from ‘Solution > 
Define Loads > Delete’ or ‘Preprocessor > Loads > Define Loads > Delete’. 

ix) Apply zero load (or a very small load compared to P for numerical stability). 
x) Save the Load Step files 2, 4, 6 and 8 with ‘time at the end of load step’ values 

2⋅∆t, 4⋅∆t, 6⋅∆t and 8⋅∆t respectively. 
xi) Go to ‘Solution > Solve > From LS Files’. Set ‘Starting LS file number’ as 1, 

‘Ending LS file number’ as 8, ‘File number increment’ as 1, and click ‘Ok’ to 
start the solution. 

xii) Once the solution is done, to view the results use the following procedures: 
o Viewing Plastic Strain vs. time plot at a particular point in the 

structure: 
a. Open the ‘Time History Variables’ window by clicking on the 

‘TimeHist PostPro’ menu or by using ‘TimeHist PostPro > 
Variable Viewer’. 

b. Click on the green ‘+’ button at the upper left corner of the 
window. 

c. In the ‘Result Item’ double-click on item to open it’s sub 
contents. Hence select ‘Nodal Solution > Plastic Strain > von 
Mises plastic strain’. Click ‘Ok’ 

d. Ansys will prompt to select a node from the model. Click on a 
node at which investigation regarding occurrence of shakedown 
is sought. Click ‘Ok’. 

e. A new item will be added to the list in the ‘Time History 
Variables’ window. Select that item and click on the ‘graph data’ 
button at the left side of the toolbar. This will plot the graph of 
Plastic Strain with time at that node. 

 
Typically, for a point where plastic strain takes place at the very 
first cycle, and subsequent shakedown has taken place, the graph 
will look as follows: 
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fig - 10 

 
o Animate results over time: 

a. Read the first set of results from ‘General PostProc > Read 
Results > First Set’. 

b. In the utility menu (the text menu at the top of the window), 
‘PlotCtrls > Animate > Over Time…’. 

c. Change number of animation frames to 50. Select ‘Load Step 
Range’ and type 1 to 8 in the text boxes below. 

d. Select the item for which contour animation is to be done and 
click ‘Ok’. 

 
The von Mises Plastic Strain vs. time plots at the different nodes are of special 
importance for prediction regarding shakedown. Shakedown will be said to have 
taken place at a node if the value of von Mises plastic strain at the node approaches a 
steady value with time. But if it goes on raising steadily or increasingly, then 
ratcheting may be said to have taken place. The other case that may happen is that the 
von Mises plastic strain remains zero throughout. In that case it may be concluded 
that the material at that node hasn’t crossed the yield point at all. 
To draw conclusion about the results, the analyst need to investigate the Plastic Strain 
vs. time plot at several nodes in the structure, especially the critical points where the 
stress intensities or the equivalent stresses are expected to be high. If at all the nodes it 
is found that shakedown has taken place within these 4 cycles, then it may be 
concluded that shakedown has taken place for the structure under that load set. 
However, occurrence of ratcheting at some local bounded regions may be allowed to 
some extent. 
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Appendix-C – An attempt of calculations for Melan’s theorem using Element Tables in Ansys 

 
It is possible to perform all the calculations for Melan’s theorem using Ansys element 
tables, but at a cost of substantial amount of labor. Hence the analyst may choose to 
implement the procedure mentioned in Appendix-D instead of the one mentioned 
below. However, for using the element tables, the analyst may try to proceed in the 
following steps: 

i) Perform the analysis using elastic-perfectly plastic material model as 
described in Appendix-A till the near collapse load is reached. 

ii) Apply the last obtained Pjust lower and perform the solution once again. The 
stress field now residing in the result is the (σij )ep,l . 

iii) Go to ‘General PostProc > Element Table > Define Table’. 
iv) Click the ‘Add…’ button and select the X component of stress (SX) from the 

list. Type ‘SX1’ in the ‘User label for item’ text box. Click ‘Ok’ to add the 
item. 

v) Similarly add the stress components SY, SZ, SXY, SYZ and SZX with user 
labels SY1, SZ1, SXY1, SYZ1 and SZX1 respectively. [It may be noted here 
that for axisymmetric models, as SYZ and SZX will always be zero, they 
needn’t be included.] 

vi) Now as the (σij )ep,l  is stored, we need to create the  (σij )le,l  field. To do this, go 
to ‘Preprocessor > Material Props > Material Model’ and open the contents of 
‘Material model number 1’ by double-clicking it. Select ‘Bilinear Isotropic’ 
and delete it using ‘Edit > Delete’. Delete ‘Bilinear Isotropic’ for any other 
material present. 

vii) Solve the model once again with the same load set Pjust lower . 
viii) Follow steps (iii) to (v) to create the element tables of the stress components 

SX, SY, SZ, SXY, SYZ and SZX with user labels SX2, SY2, SZ2, SXY2, SYZ2 
and SZX2 respectively. 

ix) Now that we have got both (σij )ep,l  and  (σij )le,l , we need to perform the 
required calculations with them. The main disadvantage of operations with 
element tables is that Ansys allows a single operation between two tables at a 
time. So the analyst needs to break up his/her calculations into several single-
step calculations to perform the whole calculation. 

x) To find the self-equilibrating stress field (σij )res , use ‘General Postproc > 
Element Table > Add Items’. Set, 

o ‘User label for result’ as SX3, 
o 1st factor as 1, 
o 1st element table as SX1,  
o 2nd factor as –1, 
o 2nd element table item as SX2, and 
o Constant as 0. 

Click ‘Ok’. 
Go to ‘General PostProc > Element Table > Define Table’ to check if ‘SX3’ 
has been added. 

xi) Similarly, create SY3, SZ3, SXY3, SYZ3 and SZX3. 
xii) As it has already been made evident, in the previous few steps we subtracted 

each components of (σij )el,l  from  (σij )ep,l  to obtain (σij )res . It is also possible 
to perform multiplication, find absolute value, determine maximum or 
minimum among different table items at each node, or exponentiate (square, 
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cube, square-root, etc) the items in the table using the tools under  ‘General 
Postproc > Element Table’. 

xiii) Next step is to find the principle stress components of (σij )res . The calculations 
involved in doing so are rather tedious and doing so using Ansys element 
tables would require lots of steps. The detailed equations involved for the 
calculations can be found in any standard text book on advanced solid 
mechanics. The calculations involved in determining the principal stresses 
from the component stresses are described in step ii. of the pseudo-algorithm 
in Appendix-E. However, the problem is a bit less severe when the model is 
plane stress, where SZ, SYZ & SZX are all zero. 

However in any case, the calculations involved are quite tedious to be performed one 
step at a time using the element table operations. Hence it may be advised to follow 
the method described in Appendix-D. 

 
Appendix – D – Calculations for Melan’s theorem using a computational code to read the 

stress fields as obtained from an Ansys run 
 

The easiest and most flexible way of dealing with the components of (σij )ep,l  and  
(σij)le,l is to export these stress fields from Ansys and read them using a program 
written in any convenient programming language. Calculating α and β is then just a 
matter of manipulation with the components. 
Below is described the procedure of exporting the stress fields from Ansys to files in 
ASCII text format which can be read with some computer program: 

i) Perform the analysis using elastic-perfectly plastic material model as 
described in Appendix-A till the near collapse load is reached. 

ii) Apply the last obtained Pjust lower and perform the solution once again. The 
stress field now residing in the result is the (σij )ep,l . 

iii) In the utility menu, go to ‘List > Results > Nodal Solution’. Select ‘Stress’ 
from the left list, and ‘components SCOMP’ from the right. Click ‘Ok’ to list 
the stress components. In the list window, use ‘File > Save as…’ to save the 
list in ‘.lis’ file format. This list file may now be easily read using a program. 

iv) Now as the (σij )ep,l  is stored in a file, we need to create the  (σij )le,l  field. To 
do this, go to ‘Preprocessor > Material Props > Material Model’ and open the 
contents of ‘Material model number 1’ by double-clicking it. Select ‘Bilinear 
Isotropic’ and delete it using ‘Edit > Delete’. Delete ‘Bilinear Isotropic’ for 
any other material present. 

v) Solve the model once again with the same load set Pjust lower . 
vi) Once again save the stress components’ list as a ‘.lis’ file as described in step 

(iii). 
vii) Refer to Appendix-E for working with the two stress fields obtained using a 

computer programming language. 
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Appendix-E – Pseudo-code of the VB program developed for determination of α and β from 

the stress fields using Melan’s theorem 
 

Using Appendix-D both the stress tensors (σij )ep,l  and  (σij)le,l  are obtained at each 
node of the model. Next we need to have a code for reading the stress fields and 
operating with them to obtain α and β . Such a code in MS Visual Basic has already 
been developed for this purpose. The analyst may make use of that. 
The pseudo-algorithm for the code is described below: 

i. Calculate (σij )res by subtracting each component in (σij)le,l  from (σij )ep,l  for all 
the nodes. 

ii. Find the Equivalent Stress (for von Mise’s criteria) or the Stress intensity (for 
Tresca’s criteria) at each node. For calculating these, one need to first 
determine the principle stresses from the component stresses of (σij )res at each 
node. The following sets of equation may be helpful: 
 
If σx, σy, σz, σxy, σyz, and σzx are the stress components, then define the stress 
invariants as, 

J1 = σx + σy + σz  
J2 = σx·σy + σy·σz + σz·σx –  σxy

2 – σyz
2 – σzx

2  
J3 = σx·σy·σz + 2·σxy·σyz·σzx – σz·σxy

2 – σx·σyz
2 – σy·σzx

2  
Let, 

3

3
121

27
2

3
JJJJG −−=  

3

2
1

2
JJH +−=  

Determine θ  from the equation, 
2

3

32
3cos

−

⎟
⎠
⎞

⎜
⎝
⎛=

HGθ  

Let 
3
γ  , 

3
2πγ +  and 

3
4πγ +  be the three solutions of θ . Then the principal 

stresses are given by the equation, 

θσ cos
3

2
3

1 HJ
+=  

from which the three principal stresses, σ1, σ2 and σ3 are obtained for the three 
values of θ . 
 
Once the principal stresses are obtained, 
Equivalent Stress (for von Mise’s criteria) is given by, 

( ) ( ) ({ })2
13

2
32

2
212

1 σσσσσσσ −+−+−=eq  

 
and Stress intensity (for Tresca’s criteria) is given by, 

( )133221int ,,max σσσσσσσ −−−=  

 
iii. Now check at each node if the Equivalent Stress (or the Stress Intensity) 

satisfies the yield condition. Hence two cases may arise: 
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Case I : Yield condition is satisfied at all nodes: 

Then β = 1 and α = 1. Hence, shakedown load is equal to the collapse 
load. Skip all the following steps. 

Case II: Yield condition is not satisfied at some point. 
Determine the node where the Equivalent Stress (or the Stress 
Intensity) is the maximum. Then, 

β = yield stress / this maximum stress. 
 

iv. When β ≠1, at each node do the following: 
a. Calculate (σij )res,co multiplying each component of  (σij )res  by β. 

(σij )res,co = β·(σij )res 
 

b. Assume values of α' from 0 to 1 at steps ∆α' (may be done in a ‘For 
loop’) and check if the following stress tensor satisfies yield 
condition (for this, the equations of step ii. may again be used): 

(σij )'  = (σij )res,co + α'·(σij )le,l 
 

c. Hence at each node a permissible range of α' will be obtained for 
which (σij )'  satisfies the yield condition. Let this range be 
represented by ( )'

2
'
1 ,αα . 

 

v. Now that we have obtained a range ( )'
2

'
1 ,αα  for each node, we find the 

common range of all these by finding their intersection. The range hence 
obtained is the permissible range of α' . The highest value in this range (i.e. the 
upper limit) gives the required value of α . 

vi. Hence, the shakedown load is given by, 
PSD = α·Plim
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Appendix-F – Verification of the method for finding Collapse Load (Appendix-A) and 

Shakedown Load (Appendix-B, D and E) by re-performing a Finite Element Analysis 
 

For the purpose of validation of the developed methods described in Appendix-A, D 
and E, a sample problem consisting of shell and plate was taken for which collapse 
load and the parameters α and β from Melan’s theorem has already been determined 
using some alternative routes in the ‘Design by Analysis CD Manual’ issued by 
European Pressure Equipment Research Council, University of Strathclyde. The 
results obtained by these methods were in satisfactory agreement with those of the 
manual. 
 
The following figures show the meshed model: 
 

 
fig - 11 
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→ fig - 12 
 

The dimensions used are showed in the following figure: 

→ fig - 13 
 

The total height of the model is 443mm. 
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Element type: As used in the original problem, here the element used was 4-node, 2-D 

axisymmetric solid PLANE42. The number of elements generated in the present 
case was 1743 using free meshing tool. 

Boundary Conditions: Zero vertical displacement was applied on the undisturbed end 
of the shell (the horizontal line at the upper end of the model). Symmetry 
boundary conditions applied on the center of the flat shell (the leftmost vertical 
line). 

Loads: A uniform pressure P was applied on the inner surface of the model, i.e. the 
upper surface of the plate, the left surface of the shell and the inner surface of 
the circle. 

Material Properties: The modulus of elasticity of the material in the whole structure is 
E = 212Gpa. The yield stresses were chosen to be 255Mpa for the shell and 
245Mpa for the plate materials. 

 
Results obtained: 

i. By following the method described in Appendix-A, the collapse load 
obtained was approximately 21.5MPa. 

ii. As described in 4.2., the values of α and β obtained using the MS Visual 
Basic program were  β = 0.4445 and α = 0.6217. 

[Notes A: 
a. The value of  ∆α'  used was 0.0001,  
b. As it was found from the plastic strain contour plot at load 21.5MPa that 

the plastic collapse begins in the plate, the value of yield stress used for 
calculations for Melan’s theorem in the code was assumed to be 
245Mpa. This was done for simplification of the code and the procedure. 
But a more rigorous and correct approach would have been to use 
different values for yield stress at different nodes depending on in which 
part of the model the node lies.] 

iii. Hence the shakedown load is given by, PSD = 0.6217×21.5Mpa = 
13.37MPa. 

 
Comparison with DBA CD Manual: 

The collapse load used in the DBA CD Manual for calculation of shakedown 
load is 21.43Mpa, and The values of α and β obtained were α = 0.621 and  β = 
0.444. The shakedown load was hence PSD = 13.3Mpa. 

 
Hence it can be concluded that the results obtained are in quite agreement with those 
of the DBA CD Manual. 
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The following figure show the plastic strain at load P = 21.5MPa at a region of high 
stress (near the neck of the structure): 

 
fig - 14 

 
Determining if shakedown occurs at the shakedown load 
 

Now as the shakedown load was obtained using Melan’s theorem, the procedure 
described in Appendix-B was used on the same model as described above to 
determine if shakedown occurs at this load of PSD=13.37Mpa. 
The following plot shows the plastic strain vs. time curve a node near the high-
stressed neck of the structure. For the other nodes either the plastic strain remained 
zero throughout, or shakedown had taken place just after the first cycle similar to the 
plot shown. 

 
fig –15 Plastic strain vs. Time plot at node no. 319 – a point near the high stressed 

region 
 
Hence it may be concluded that shakedown takes place at the determined load of 
13.37Mpa. 
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Appendix-G – Elements used, Material Properties, Boundary conditions applied and other 

details for the tube to tubesheet junction simulation of the boiler 
 
 1 Component TUBE TO TUBESHEET JOINT   
 2 Analysis type COUPLED FIELD (STATIC AND THERMAL)   
 3 Software used Ansys 8.0   

 
4 Element type 

1st order Coupled-field Axisymmertic Elements PLANE13, 
Mechanical Contact Element CONTAC48, Thermal Contact and 
Target Elements CONTA172 and TARGET169   

 5 No of elements 3687 PLANE13, 1558 CONTAC48, 510 CONTA172, 510 TARGET 
169   

 6 No of nodes 4923   
                           
 7 Design data :                     
                           
   Design code ASME SECT. VIII, DIV 2, ED.2001, AD.2003. & TEMA LATEST ED.  
   Corrosion allowance SHELL SIDE - 1MM, TUBE SIDE - 1 MM (NIL FOR TUBES)   
                           
                           
 8 Material properties :                  
                           
  

 

No Part Material 
Design 

Temp deg 
C 

All. Stress, 
Sm, 

kgf/(mm^2)

Mod of 
elasticity, 

E, 
kgf/(mm^2)

Thermal cond. 
Kcal/(s-mm-C)

Coeff of 
thermal exp. 
[mm/mm/C] 

Yield 
Strength, Y, 
kgf/(mm^2) 

 
  
 

1 TUBESHEET SA 336 GR 
F22 CL3 480 12.20 19290.25 8.6416E-06 1.35E-05 22.8 

 

  

 
2 TUBE SA 213 GR 

T22 380 12.58 19290.25 8.6416E-06 1.35E-05 18.89 
 

  

 
3 

LAS 
PORTION 

OF 
FERRULE 

SA 213 GR 
T22 480 9.73 18240.52 8.2575E-06 1.42E-05 18.03 

 

 *  

 
4 FERRULE 

INCONEL 600 
(SB 167 UNS 

NO6600) 
480 11.29

  
18768.55 5.0824E-06 1.46E-05 19.24 

 
                           

  * Allowable stress as per ASME Section VIII, Div-1   
 
                           
 9 DOF constrains and Mechanical boundary conditions:       
                           
   Pressure:                    
                        

    
  

Location Pressure [kgf/(mm^2)] 
  

    
  

Tube Side 2.45 
  

    
  

Shell Side 1.30 
  

    
  

Upper end of tube (axial loading) -1.319 
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   DOF constrains:             
                           

    

  
Location and DOF name Value 

  

    

  

Lower surface of tubesheet - vertical 
displacement (UY) 0 

  
                        
                        
 10 Thermal boundary conditions:       
                           
   Convection Boundary conditions:             
                        

    
  

Location Conv. Heat transfer 
coeff. [kcal/(s-C-mm^2)] Temperature (deg C) 

  
    
  

Below tubesheet 9.73E-07 455 
  

    
  

Inside tube 7.55E-07 455 
  

    
  

Outside tube (Shell 
side) 5.56E-06 324 

  
                           
   Heat flux boundary condition:             
                           

    

  
Location Heat flux 

  

    

  

On the extreme edge of the portion of 
tubesheet under consideration 0 

  
                        
                        

 
 
 
 
 

Appendix-H – Results obtained from the tube to tubesheet junction simulation of the boiler 
 
 
The stress values were obtained from the results and hence the stress intensity contour 
plots were obtained. Moreover the stresses were linearized at some critical sections 
(refer to fig 5). Hence the membrane stress intensities and bending stress intensities 
were obtained at those sections. 
 
The stress contour plots and the stress values obtained after liniarization at the 
sections cannot be shown in this report because of proprietary reasons. 
However the temperature contour plots at two positions in the model are shown in the 
following page. 
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12   Temperature Contour Plots: 12   Temperature Contour Plots: 

  
  

  fig – 16a

  fig – 16b 
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Appendix-I – Documentation made for Working manually with the MS Access Material 
Database 

 
I.1. Retrieving a Value from the database 

To extract a value from the database proceed through the following steps: 
i) Open the ‘Materials’ database and find out the material name of which the 

property value is sought. 
ii) Note the ID number that is present in a property field, the value of which is 

being sought. 
iii) Open the ‘Data_’ table corresponding to that property. 
iv) Scroll down and search for the set of records for which the ‘ID’ fields contain 

the same ID number as that noted from the ‘Materials’ table in step ii) (i.e. the 
property data set). All such records’ Field 1 (temperature) and Field 2 
(property value) gives the property values at different temperature points. 

 
I.2. Editing the already existing Values 

To edit a property value of the material, or the temperature entries, just go to the 
corresponding position as described in I.1. and edit as required. 
 

I.3. Adding values to an already existing material’s property 

To add a temperature and value point for an already existing material in the database, 
do the following: 

i) Open the ‘Materials’ database and find out the material name of which 
the property value is sought. 

ii) Note the ID number that is present in a property field, the value of 
which is being sought. 

iii) Open the ‘Data_’ table corresponding to that property. 
iv) Add a record at the end of the ‘Data_’ table with Field 0 equal to the 

ID number noted in step ii) and Field 1 and Field 2 equal to the 
temperature and property value to be added. Note that you must use 8F 
as temperature units and the unit system in accordance to ASME Sec II 
Part D for the property values. 

v) Sort the database first with respect to Temperature, next with respect to 
ID. 

 
I.4. Adding a new material to the database 

To add a new material to the database, proceed as follows: 
i) Open the ‘Materials’ database and add a new record at the end of the 

database with Field 0 (Material Name) as the name of the material. 
ii) For a particular property, check whether the property data set intended 

to be inputted already exists in the corresponding ‘Data_’ property 
table. [There is no definite procedure for doing this. One may check it 
from knowledge of the material groupings made in the ASME code, or 
may go through all the property data sets in the ‘Data_’ table and find 
out if the dataset already exists] 
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iii) Hence, two cases may arise now: 

Case I: The property data set for the material’s particular property 
already exists: 
In such a case, just put the ID number of the property data set into 
the appropriate field beside the material’s name in the ‘Materials’ 
table. 

Case II: A new property data set needs to be added for the particular 
property: 
Pursue the following steps: 

i) Open the ‘Data_’ property table. 
ii) Scroll down the records to find what is the maximum number 

that has been used as ID number in the table. Hence determine 
the next available ID. 

iii) Open the corresponding ‘ID_’ property table and make sure 
that the ID number exists. If not, add it. 

iv) Open the  ‘Materials’ table and put the foresaid ID number in 
the appropriate field beside the material. 

v) Go back to the ‘Data_’ table and keep adding records with the 
same ID number in the ‘ID’ field, and temperature & property 
values in the fields 1 & 2 respectively. 

 
 
Appendix-J -- Documentation made for Working with the forms developed in the MS Access 

Materials database 
 
J.1. Converting the MS Access database to I-DEAS Universal file of material properties 

The database can be converted to I-DEAS 11NX universal file. The steps involved 
are: 

i) The file ‘IDEAS_material_format.dat’ and ‘IDEAS_materials_header.dat’ 
should present in the same folder as the access database file ‘Material 
Properties.mdb’. If they are not present, copy them into the folder of the 
database. 

ii) Double-click to open the ‘Export database to IDEAS UNV file’ form. Select 
the path and file name for exporting the database using the ‘Browse…’ button. 

iii) Click ‘Export database’ to export database. 
 

J.2. Finding and Interpolating values using different units 

For seeking a particular property value at a  particular temperature by linear 
interpolation upon the database values, perform the followings: 

i) Open the ‘Seek/Interpolate’ form. 
ii) Select the material name and the property name from the respective drop-

down lists. 
iii) Select the desired units for temperature and the property value. 
iv) Click the ‘Seek’ button. 

 
Notes B: 
o All the values displayed in the form are in the units selected by the user. 
o The values displayed do not get updated unless the ‘Seek’ button is clicked. 
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o The user may wish to open the ‘Materials’ table or the property ‘Data_’ table 

directly at the positions from where the last values have been sought, by clicking 
the ‘Open 'Materials' Table’ and ‘Open Property Value database Table’ buttons 
respectively. 

 
J.3. Listing, adding, editing and deleting records of the existing database 

The ‘List/Edit/Add’ for gives the user the ultimate authority on the database in an 
user-friendly manner. Though care has been taken to ensure that the form works 
properly under all circumstances and don’t crash, it is always advisable to create a 
backup of the database before editing/modifying it with this form. 
 
To add, edit and/or delete records from a property data set using this form, pursue the 
following steps: 

i) Open the ‘List/Edit/Add’ form. 
ii) Select a material from the drop-down list of which a property data set is 

intended to be edited/modified. 
iii) Select the material property from the drop-down list. 
iv) Now note: 

o This has loaded the temperature & value points of the property data set 
assigned to the selected material’s selected property, which will hence 
be displayed in the list. 

o In the upper half of the right side of the list, the user may see the ID of 
the currently loaded property data set. 

v) Click on a record in the list. This will transfer it’s value to the ‘Temperature’ 
and ‘Property Value’ text boxes on the right side of the list. 

vi) Make change to the values in the text box or type completely new values and 
click the ‘Add Record’ or ‘Update Record’ Button. Click ‘Delete Record’ to 
delete the selected record. 

vii) After the desired changes have been made, click the ‘Update database with 
current list’ button at the bottom of the form. 

viii) A dialog box will pop up asking for confirmation whether to 
overwrite/update. Click ‘yes’ to save the changes. 

 
Notes C: 

o ‘Add Record’ will add a new temperature and property value point. The 
record will be added at the position of currently selected record in the list. 
However the position of a record is of not much importance other than 
ease of viewing. ‘Update Record’ will update the presently selected record 
with the values in the text box. ‘Delete Record’ will delete the presently 
selected record. 

o The user may wish to view/enter values in different unit systems by 
choosing the appropriate units from the ‘Material Property unit’ and 
‘Temperature unit’ drop-down lists in the upper right side of the form. 

o The user may chose to work in any unit system throughout without 
worrying what the unit system of the actual database is. The program takes 
total care of all the unit conversions. 

o The user may click the ‘Sort List’ button to view the list sorted in 
ascending order of temperature. 
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o The user must click the ‘Update database with current list’ button to save 

the changes made to the property data set, before he/she can switch to 
some other material or property. Once switched to other material or 
property, the unsaved changes made to the already load set will be lost. 

o Though, by default the ID number of the data set to which the currently 
loaded list to be saved will remain the original ID of the Set, the user may 
opt to save the list to a data set with a different ID by typing the desired ID 
number in the ‘Save this property with ID set number’ text box. The ID 
number should be a positive integer less than 1000. Type ‘NEW’ or ‘0’ to 
create a new data set with the lowest unoccupied ID number. 

 
J.4. Adding a new material to the database and creating, editing it’s property values 

It is also possible to add a new material to the database using the ‘List/Edit/Add’ 
form. To do so, the steps involved are: 

i) In the ‘List/Edit/Add’ form type the name of the new material to be added in 
the ‘Material Name’ box. 

ii) Type the composition of the material in the ‘Composition’ box. Or select an 
already existing composition from the drop-down list. [For typing new 
material composition, use the standard format as used for the other 
materials.] 

iii) Click the ‘Add Material’ button to add the material to the database. 
iv) Do not change the material name or close the form unless the following 

points have been considered. Please read on … 
 
Depending on the composition of the material the program may assign some default 
values to the ID numbers for the different properties of the material if the composition 
already existed in the database. The user may however opt to change the property set 
ID numbers for the material to some other value, or may create a new property data 
set by entering new values. These are to be done in the following steps: 
 

i) Select the property whose ID/values is to be changed/modified. 

Note: If some default ID number had been assigned to the property by the 
program, the corresponding data set will be displayed in the list and the ID 
number will be displayed beside the list. Else the list will remain blank and 
the ID number will be displayed as 0. 
 

ii) If required, to load an already existing property data set to the list, type the ID 
number of the set into the ‘Load an already existing property Set’ text box and 
click ‘Load set to list’ button. This will load the set to the list. 

iii) Now the user may edit the list as described in steps v) and vi) of J.3. New 
temperature and value points may be added as desired. 

 
Tips: To Add several temperature and value points to the list, the following 
key combinations may be useful: 

a. Use the ‘Space bar’, ‘up arrow’ or ‘down arrow’ keys to toggle 
between the ‘Temperature’ and ‘Property Value’ text boxes. 

b. Use the Enter key (or Carriage Return) to add the presently typed 
temperature and property value to the list. 
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iv) Once the list contains the desired values, click the ‘Update database with 

current list’ button to add the list to the database as a property data set. 
 

Note: The ‘Save this property data set with ID number’ text box indicates 
the ID of the data set to which the values will be saved. The user may chose 
to use a different number or may type ‘NEW’ or ‘0’ to create a new data set 
with the lowest unoccupied ID number. However, if unsure, the user may 
leave this value as it is. 

 
iv) A data set addition/modification confirmation message box will pop-up. Click 

‘Yes’ to add/modify. 
 
Notes: All the notes mentioned under ‘Notes C’ will also apply here. 

 

J.5.2. Restrictions of the ‘List/Edit/Add’ form 

The ‘List/Edit/Add’ form has some restrictions. They are primarily to prevent 
accidental loss/damage of the database. The restrictions are: 
 

i. The form cannot be used to delete a material from the database. 
ii. The form cannot be used to delete a data set. However it can be used to modify 

it’s records, add to the records or delete records one by one. 
iii. The form cannot be used to modify the name, composition or the IDs assigned 

to the properties of an already existing material. Any of these parameters/values 
are to be assigned at the time the material has been created. 

 
J.5.1. Restrictions on the database for the code to work properly (Limitations) 

The following constrains should be maintained on the database to ensure that the 
forms work properly. 

i. The ID number of the property data sets must be a positive integer less than 
1000. 

ii. There shouldn’t be more than 100 records in each data set. 
iii. The standard format should be used for representation of material composition. 

 
If the above restrictions are to be relaxed, the corresponding changes must be made 
to the codes of the form. 

 
Appendix-K – Results of calculation for stresses on the welds and bolts of the support used for 

holding a pressure vessel in the workshop 
 

Force on iith bolt (Fi) :     
     

ii Force Stress 
1 27767.07 2.73E+07 
2 36279.43 3.56E+07 
3 39268.57 3.86E+07 
4 36279.43 3.56E+07 
5 27767.07 2.73E+07 
6 15027.43 1.48E+07 
7 0.00 4.73E-09 
8 -15027.43 -1.48E+07 
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ii Force Stress 
9 -27767.07 -2.73E+07 

10 -36279.43 -3.56E+07 
11 -39268.57 -3.86E+07 
12 -36279.43 -3.56E+07 
13 -27767.07 -2.73E+07 

Sum = 0 0 
 

Stress on weld at position (θ) :   
φ+α = 35  

360+(φ-α) = 325  
   

θ (degree) [(φ+α) -- 360+(φ-α)] θ (radians) Stress 
35 0.61 9.37E+06 
45 0.79 1.16E+07 
55 0.96 1.34E+07 
65 1.13 1.48E+07 
75 1.31 1.58E+07 
85 1.48 1.63E+07 
95 1.66 1.63E+07 

105 1.83 1.58E+07 
115 2.01 1.48E+07 
125 2.18 1.34E+07 
135 2.36 1.16E+07 
145 2.53 9.37E+06 
155 2.71 6.91E+06 
165 2.88 4.23E+06 
175 3.05 1.42E+06 
185 3.23 -1.42E+06 
195 3.40 -4.23E+06 
205 3.58 -6.91E+06 
215 3.75 -9.37E+06 
225 3.93 -1.16E+07 
235 4.10 -1.34E+07 
245 4.28 -1.48E+07 
255 4.45 -1.58E+07 
265 4.63 -1.63E+07 
275 4.80 -1.63E+07 
285 4.97 -1.58E+07 
295 5.15 -1.48E+07 
305 5.32 -1.34E+07 
315 5.50 -1.16E+07 
325 5.67 -9.37E+06 

Sum =  6.33E-08 
 

Average shear stresses:  
  

Avg. shear stress on bolt = 25921246.7
Avg. shear stress on weld = 6853273.33
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